Mac OS X 系統命令 (持續補充中

2021-06-06 06:19:13 字數 2052 閱讀 9172

剛開始接觸mac os x不久,對unix也不太熟悉,記錄一些容易忘記的操作。

sudo command 不用輸入密碼

$echo 「password」  > ~/temp/temp.txt

$sudo -s id < ~/temp/temp.txt

注:以上兩步可以解決臨時sudo不用輸入密碼的問題,但不是長久之計。其實run一次sudo command並輸入密碼之後就直接記住密碼啦。寫檔案記錄的方式是為了可以指令碼化所有的操作,輸入乙個password就可以一切搞定。

$sudo cp /etc/sudoers /etmp/sudoers

$sudo chmode 777 /temp/sudoers

$echo 「%admin all=(all) nopasswd: all」 >> /temp/sudoers

$sudo chmod 440 /temp/sudoers

$sudo cp /temp/sudoers /etc/sudoers

list all network services

$sudo networksetup -listallnetworkservices

an asterisk (*) denotes that a network services is disabled

bluetooth dun

ethernet

firewire

wi-fi

bluetooth pan

get ethernet info

$sudo networksetup -getinfo ethernet

……

find machine  dns name

$nslookup 10.162.111.111

……

set machine host name

$scutil –set hostname 「your host name」

set machine local host name

$scutil –set localhostname 「your local host name」

set machine computer name

$scutil –set computername 「your computer name」

三個name的區別:

computer name 相當於乙個alias 可以輸入特殊字元,可以忽略它的存在

host name 在網路中使用的名字,網路中發生衝突時,有可能會被dns自動修改(待確認)

local host name 跟host name差不多,一般兩個保持統一就ok啦,沒做更多實驗 ,待更新。

turn off auto update

$sudo softwareupdate –schedule off

turn off bluetooth

turn off fireware

disable remote

取消程式狀態儲存

顯示所有隱藏檔案

restore mac os x

建立乙個restore盤

$mkdir /volumes/restore

$mount -t smbfs //user@url /volumes/restore

restore命令

$sudo asr restore –source 「/volumes/restore/os_x_10.7.3_us.dmg」 –target 「/dev/disk0s2″ — erase –noprompt –noverify

設定啟動盤

$sudo bless -device 「/dev/disk0s2″ -setboot

持續補充 linux命令

1.修改主機名 hostnamectl set hostname 主機名 su 或者 bash 2.建立使用者 useradd 使用者名稱 3.解壓tar.gz到指定目錄 tar xzvf 檔名.tar.gz c 解壓目錄 解壓到當前目錄 tar xvf 檔名.tar.gz 4.檢視伺服器資訊 檢視...

常用linux命令 持續補充

1.切換root和user 1 切換到root使用者 執行 sudo su 2 從root使用者切回user使用者 exit 2.複製檔案 語法 cp 選項 原始檔或目錄 目標檔案或目錄 需要說明的是,為防止使用者在不經意的情況下用cp命令破壞另乙個檔案,如使用者指定的目標檔名是乙個已存在的檔名,用...

前端專案開發(持續補充中)

平台支援 指令碼錯誤監控 網路劫持監控 使用者反饋平台團隊協作 資料意識 規範 技術預演 cr 重構研發架構 模組化設計 工程化質量保障 發布流程架構設計 框架選型 分層設計 安全防護研發流程 腳手架 打包工具 開發除錯 自動化測試 測試發布效能優化 資料快取 非同步載入 離線包服務端渲染頁面層 業...