POJ 1321 棋盤問題(dfs八皇后變形)

2022-05-06 03:54:10 字數 1652 閱讀 7529

棋盤問題

time limit:1000ms

memory limit:10000k

total submissions:25147

accepted:12424

description

在乙個給定形狀的棋盤(形狀可能是不規則的)上面擺放棋子,棋子沒有區別。要求擺放時任意的兩個棋子不能放在棋盤中的同一行或者同一列,請程式設計求解對於給定形狀和大小的棋盤,擺放k個棋子的所有可行的擺放方案c。

input

輸入含有多組測試資料。 

每組資料的第一行是兩個正整數,n k,用乙個空格隔開,表示了將在乙個n*n的矩陣內描述棋盤,以及擺放棋子的數目。 n <= 8 , k <= n 

當為-1 -1時表示輸入結束。 

隨後的n行描述了棋盤的形狀:每行有n個字元,其中 # 表示棋盤區域, . 表示空白區域(資料保證不出現多餘的空白行或者空白列)。 

output

對於每一組資料,給出一行輸出,輸出擺放的方案數目c (資料保證c<2^31)。

sample input

2 1

#..#

4 4...#

..#.

.#..

#...

-1 -1

sample output

2

1

source

解題思路:

類似於八皇后,只不過對於皇后的數目有了要求,八皇后中,一定要去皇后的數目==棋盤的維數,但是這裡,棋子的個數!=棋盤的維數,所以,我們

要採用不同的方式來維護。

int x = pos/n;

int y = pos%n;

這在處理有關二維的dfs問題中,很常見,也很好用,通過這樣的方法,我們就能控制每次棋子的移動位置,然後分別判斷row和col和grid來決定

是不是放棋子,如果能放入棋子的話,我們就說標記下->dfs->回溯。

**:# include# include# include# include# include# include# include# include# include# includeusing namespace std;

typedef long long ll;

typedef unsigned long long ull;

# define inf 999999999

# define max 10

int col[max];

int row[max];

char grid[max][max];

int n,k;

int ans;

void input()

else

}getchar();

}}void dfs( int pos,int step )

while ( pos < n*n )

pos++;

}}int main(void)

memset(col,0,sizeof(col));

memset(row,0,sizeof(row));

input();

ans = 0;

dfs(0,0);

cout<**:

POJ 1321 棋盤問題(棋盤DFS)

棋盤問題 思路 分層查詢,逐行深搜。注意k n時的處理。1 include 2 include 3 include 4 include 5 include 6 include 7 include 8 include 9 include 10 define ll long long 11 define...

POJ 1321 棋盤問題 DFS

題意 在乙個給定形狀的棋盤 形狀可能是不規則的 上面擺放棋子,棋子沒有區別。要求擺放時任意的兩個棋子不能放在棋盤中的同一行或者同一列,請程式設計求解對於給定形狀和大小的棋盤,擺放k個棋子的所有可行的擺放方案c。題解 include using namespace std define n 10 bo...

poj 1321 棋盤問題(DFS)

大概題意就是給你乙個棋盤,讓你放棋子,求在棋盤n n上的 放上k個棋子的所有情況的數目。要求擺放時任意的兩個棋子不能放在棋盤中的同一行或者同一列。深搜可以搜尋出所有答案。直接看 include includebool chess 9 9 bool vis col 9 int n,k,ans void...