vue安裝及升級

2022-06-23 14:21:14 字數 1715 閱讀 8516

先裝好note.js

安裝過程很簡單,一直點下一步就ok了。

1.1我們通過開啟命令列工具(win+r),輸入node -v檢視node的版本,若出現相應的版本號說明你安裝成功了

1.2.npm包管理器,是整合在node中的,所以安裝了node也就有了npm,直接輸入npm -v命令,顯示npm的版本資訊

現在node環境已經安裝完成了,npm包管理器也有了,聽說由於有些npm資源被遮蔽或者是國外資源的原因,經常會導致npm安裝依賴包的時候失敗,所以我們還需要npm的國內映象----cnpm(**的映象)

2.安裝cnpm

在命令列中輸入 npm install -g cnpm --registry= ,然後等待,沒報錯表示安裝成功,(我的已經安裝過了,顯示更新成功的資訊),如下圖:

完成之後,我們就可以用cnpm代替npm來安裝依賴包了。

3.安裝vue-cli腳手架構建工具

在命令列執行命令npm install -g vue-cli然後等待安裝完成。如下圖:

升級

在 使用npm install -g @vue/cli 命令安裝vue的腳手架之後,執行vue  -v 發現vue的版本竟然是2.9.6,

然後各種解除安裝重灌一直都沒有用,從網上找了各種方法,分別為以下幾種:

1.解除安裝重新安裝

(vue升級到3版本之後   將npm install -g vue-cli 命令改為了npm install -g @vue/cli,

可是我本來執行的就是這個,很冤~~~ 這個已經沒用了~~~~~)

2.環境配置問題,

(其實我安裝nodejs的時候就以及做了這一系列操作,所以現在就不用嘗試了)

我就開始了自己摸索~~

之前是解除安裝了vue的腳手架,但是沒有試過全域性解除安裝,(可能問題就出在這了呢,畢竟當初是全域性安裝的,嘗試一下),全域性解除安裝之前安裝過的vue腳手架

因為我使用了兩種方式安裝vue的腳手架,分別是   npm install -g vue-cli   和   npm install -g @vue/cli    所以此時我把這兩種都解除安裝了,

npm uninstall -g vue-cli

npm uninstall -g @vue/cli 

intellij idea中'vue' 不是內部或外部命令,也不是可執行的程式或批處理檔案。

【現象】

【解決方法】

執行npm install -g webpack後,重啟intellij idea

Vue路由模式及監聽

當然詳細情況還是看一下vue的官網咖 官網hash模式下 預設 new vuerouter window addeventlistener...

vue路由介紹及使用

vue router 官方提供的vue路由外掛 使用流程 const routes path 路徑 component 元件名 建立路由 c...

vue spa單頁開發及vue router基礎

瞭解spa頁面跳轉方式 2種 spa 單頁跳轉方式 開發 hash模式 生產 h5利於seo history pushstate test...